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Lab 
# 

What I can do What it does, examples How to do it 

1 Spatial Join 

 

table join operation in which fields 
from  one layer's attribute table are 
appended to  another layer's 
attribute table 

Analysis Toolbox > Overlay > Spatial Join 

1 Create Buffer 

 

Creates buffer polygons to a 
specified distance around  the Input 
Features. 

Arc Toolbox go to Analysis Tools → Proximity → 
Buffer 

1 Clip 

 

Extracts input features that overlay 
the clip features. 

Arc toolbox → Analysis Tools → Extract → Clip.   
- NOTE: Input feature is bigger area; clip feature is 
desired boundary. 

1 Intersect 

 

Features or portions of features 
which overlap in the  feature classes 
will be written to new output  
Feature Class. 
 

 

1 Create spatial 
bookmarks 

Spatial bookmarks save the current 
display, as zoomed in, with a name 

Click Bookmarks, then click Create 

1 Create a new layer of 
a subset of features 

Sometimes just a subset of features 
is needed in a map layer. For 
example, here you will select the 
most populated cities in Texas and 
make a new layer of just these 
cities. 

1. In the table of contents, right-click the Major 
U.S. Cities layer 
2. Click Selection, then select Create Layer from 
Selected Features. 

1 Save the project Make sure that the file is easy to 
open again in the future. 

Click the file menu and Map document properties. 
Make sure the Store relative pathnames to data 
sources is checked. 

2a Change map 
projection / 
coordinate system 

 

Change how the map is laid out 1. Right-click the Layers data frame in the table of 
contents and click Properties. 
2. Click the Coordinate System tab and click 
Predefined, Projected Coordinate Systems, World, 
Robinson (world), and OK 

 Change Projection 
ALTERNATE 
 
 
 

 In Arc Toolbox → ‘Data Management Tools’ → 
‘Projections and Transformations’ → ‘Project’. 
 



 

 Change Projection 
ALTERNATE 2 

In case the above doesn’t work, 
change the projection for the entire 
data frame 

Go to table of contents → right click on Layers 
(this is your Data Frame). → Properties → 
Coordinate System → Open Projected Coordinate 
Systems folder → Continental → North America 
→ select projection 

2a Symbolize area maps 
using size-graduated 
markers 

 

Showing variable cases on a map 1. click the Symbology tab 
2. In the show panel, click quantities and 
Graduated Symbols 
3. In the Field frame, click the value drop – down 
arrow, and click variable 
4. Use the Template button to change the symbol 
type to circle with red color fill. 
5. On the Symbology tab, set the symbol size 
range 2-12. 

2a Create a prevalence 
map using point 
markers 

 

Showing variable cases PER CAPITA 
on map 

1. Open Attribute Table 

2. In the Attributes of the variable, click , Add 
Field. 
3. Name the new field, set its Type as Double, 
then click OK. 
4. , right-click the new field name, click Field 
Calculator, and click Yes. 
5. In the Field Calculator, scroll down the Fields 
list, double-click cases variable, click the 
multiplication (*) button, type 10000, click the 
division (I) button, double-click population 
variable, and click OK. 
6. create a map from this field. 

2b Join 

 

Join Table data to a shape file.  
 
Example: You can join population 
data to a neighborhood shape. 

1. Right-click the layer you want to join the table 
data to. 
2. click Join and Relates.  
3. and then Join 
4. select both variable names that are the same in 
each data set. 

2b Select by Location 

 
 
 
 
 
 
 
 

For example, you can select for 
neighborhoods with 10 or mor 
assaults, by using the code: 
“Assault1003” >3 
 
You can use AND, OR, features in 
combination. 

In the menu click ‘Selection’ → ‘Select by 
Location’ 
 



 

2b Select by Attribute 

 

 In the menu click selection  → ‘Select by attribute’ 

2b converting polygon 
shapefile into a point 
shapefile (centroid) 

 

Useful for doing things like 
calculating total populations within 
neighborhood boundaries. This is 
accomplished by creating centroids 
in each polygon while preserving 
the attribute table. 

Open Arc Toolbox → ‘Data Management Tools’ → 
‘Features’ → ‘Feature To Point’. 

2b Sum point data 

 

Useful if you have several data 
point within a spatial boundary than 
needs to be summed. 

1. Right click the spatial layer and ‘Joins and 
Relates’ and ‘Join’. 
2. select ‘Sum’ 

2b Kernel Density 
Hotspot analysis 

 

Kernel density is a great method to 
visualize point data. It can also be 
used when we don’t want to show 
individual points data but we still 
want to convey clusters within the 
data. 

1. Open Arc toolbox → Spatial Analyst Tools → 
Density →Kernel Density. 
2. input file should be point data. Select output 
sell size.  

3a Geocode addresses 
using ArcMap 

 

Start by creating an address locator 
file.  
 
Need:  
1. data file with addresses 
2. road file 

1. System Toolboxes → Geocoding Tools → Create 
Address Locator 
2. Customize → Toolbars → Geocoding and click 
Geocode addresses button. 

3a Export data to Excel 

 
 
 
 

Analyze data in Excel, or other 
software. 
 
This creates a .dbf file 

In the Attribute Table, select Options → Export 
- Make sure ‘All records’ is selected 



3a Calculating the 
distance to the 
nearest point. 

 

Calculating the distance to the 
nearest point. 
 
- Input features: centroid point 
features 

In Arc Toolbox tool found at Analysis Tools → 
Proximity → Near 

3b inverse distance 
weighting 

 

Use measurements of a dataset 
with point data. 
 
Inverse Distance weighting works 
by assuming that data points are 
inversely proportional to distance. 

1. Activate the Geostatistical Analyst extension 
(Customize → Extensions, click Geostatistical 
Analyst) 
2. Open the Geostatistical Analyst toolbar 
(Customize→ Toolbars → Geostatistical Analyst) 

3b Kriging 

 

This calculates the relationship 
between how far apart points are 
from one another and how similar 
the concentrations are. 
 
Kriging works on the assumption 
that points in the world are related 
and correlate with one another. 

1. Geostatistical Analyst → Geostatistical Wizard 
→ Kriging 
2. Select Data Field 

3b land use regression 
(LUR) 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

use this equation and our rasters to 
calculate the average concentration 
at every location in your map. 
 
- First, need multiple raster maps. 
For example, industrial land use, 
1500 buffer; highway length in 1000 
m buffer; water area in 1000 m 
buffer; distance to city center; etc. 
 
- Second, after doing a stepwise 
multiple linear regression, develop 
formula.  
 
For example: NO2 = 16.60 + 0.02 * 
("IND_1500_10.img") + 0.30 * 
("HW_1000_10.img") + 12.01 * 
("MR_50_10.img") + 4.66 * 
("allrd_100_10") - 0.06 * 
("WTR_1000_10.img") - 0.58 * 
("D_CNTR_10.img") 

1. Create vector shapefiles to raster files 
2. Develop regression formula 
3. Open ArcToolbox go to Spatial Analyst Tools > 
Map Algebra > and Raster Calculator 
 



3b Extract Values to 
Points (For LUR 
modeling) 

 

This tool gives the values of a 
chosen raster at discrete locations 
on the map. 
 
For example, if you have a raster of 
distance to center of city, and a 
map of pollution points, then this 
tool will help determine distance to 
center for each point. 
 
You can do this action for each 
different raster map. 

1. activate the Spatial Analyst Extension (under 
the Customize tab) 
2. ArcToolbox → Spatial Analyst Tools → 
Extraction → Extract Values to Points 

4 Creating a 
population raster 
surface from the 
block point file 

 

Creates raster from point data, to 
allow for data analysis. 
 
NOTE: USE THIS FOR MY FINAL 
PAPER – census point data. First 
need to calculate ??? 

1. First set a few environment parameters 
- Go to the Geoprocessing menu, select 
Environments, then Processing Extent. Change 
Extent to however large you want your map to be. 
2. Activate spatial tools 
- Click on the Customize menu, select Extensions. 
Check Spatial Analyst. 
3. Creating new raster 

- Open ArcToolbox  , expand Spatial Analyst 
Tools > Density > Point Density 
- set input feature as point feature 
- population field will be the variable name 
- neighborhood, rectangle, 1X1, Sq km. 

4 Create new Raster 
with different values 

 

If you need to do a calculation, such 
as figuring out population density, 
you can do a calculation such as: 
“PopDensity” / 4 
 
 
 
 

ArcToolbox > Spatial Analyst Tools > Map 
Algebra, → Raster Calculator 

4 Create Distance to 
Water raster 

 

Create a raster that has higher 
values the closer a point is to a 
water body. 
 
Need: water body shape file; area 
shape file 
 
Note: north America equidistant 
contic  

- Make sure the projection of the water shape file 
is the same as the area shape file 
- Calculate distance to water 
1. ArcToolbox → Spatial Analyst Tools > Distance 
> Euclidean Distance.  
2. Set input at water shape file 
3. leave output cell size to 500 
- Adjust symbology to visualize surface. 
1. try, Geometric Intervals for symbology  
- Extract distance visualization only to area. 
1. Go to ArcToolbox > Spatial Analyst Tools > 
Extraction > open Extract by Mask.  
2. set input raster to the new water distance 
raster 



3. Set Input raster or feature mask data to area 
shape file  

 Polygon to Raster 

 

Convert polygon data to a raster 
map, so that you can do multi-
criteria analysis 

ArcToolbox → Conversion Tools → To Raster → 
Polygon to Raster 

4 Normalizing different 
raster data sets 
 
(Modify raster data 
to limit values to 
certain degree) 

 

Before combining the datasets, we 
need to normalize the values in 
each raster: The values should have 
the same scale before we can 
combine them (e.g. we cannot 
combine elevation values that 
range from 0 to 4000, with degree 
days that range from 0 to 500, with 
distance values that range from 0 to 
10000, so we will create a single 
normalized scale that goes from 0 
to 1 for each raster). 
 
For example, if you have values 
between 0 and 300, but anything 
above 200 is not valuable to your 
research, you can use these tools: 

1. ArcToolBox > Spatial Analyst Tools > Overlay > 
Fuzzy Membership.  
2. Set Input raster to raster you want to modify 
3. Set the Membership type to Linear  
4. Enter Minimum and Maximum range values of 
original raster. 
5. Leave Hedge set to NONE. 

4 Conducting Multi 
Criteria Analysis 

 

After normalizing raster data sets, 
overlay them and produce the 
predictive map. 
 
In this example, all three maps are 
weighted equally. 

1. ArcToolbox > Spatial Analyst Tools > Map 
Algebra, then double click on Raster Calculator. 
2. Put the following expression in the 
windowpane:  
("raster map 1" /3)+(" raster map 2"/3)+(" raster 
map 3"/3) 

5 Georeferencing hand 
drawn map 

 

 1. In the menu click customize -> toolbar and 
enable the georeferencing tool 
2. add tracing map.png 
3. In the georeferencing tool bar click ‘fit to 
display’ 
4. make the .png file more transparent 
5. On the georeferencing tool click the add control 
point button. Connect a few points. Then click 
update georeferencing on tool bar 
6. In the menu click customize -> toolbar and 
enable the drawing tool. Make sure the Line tool is 
selected 
7. Draw lines over the roads in the png file 
8. In the drawing tool click Drawing button and 
select ‘Convert Graphics to Feature’. 
9. Right click the Roads Layer in the table of 
content and click ‘Edit Features’ and ‘Start 
Editing’. Make sure the editing toolbar is shown in 
ArcMap (Customize→ Toolbar→ Editor) 



10. Click Editor → Editing Window → Create 
Feature Window to show the create feature 
window. In the construction window selects Line. 
11. Open the Roads layer attribute table and type: 
‘Major Functional Seasonal’. In the editor tool bar. 
Save edits and click Stop Editing. 
12. In the attribute table or the Roads Layer add 
another field of type Double and name it Length. 
Right click on the newly created field header and 
click calculate Geometry (if a window pops up, 
click ok). This will allow us to calculate the length 
of each road we created. 

 get CSV data points 
with Lat and Long 
into GIS 

 

 • Go to table of contents → right-click on 
the CSV file → display x y data →X field = 
Longitude, Y field = Latitude → click Edit 
→ Go to the Geographic Coordinate 
System folder → World → WGS 1984 

• Now, export the data point. Go to table of 
contents → right-click on the point shape 
file → Data → Export Data → select the 
data frame → make sure all data is in 
same projection 

 


